Veeva Vault 26R1 Release Notice (Self-Serve Prerelease) - Downtime Required

Maintenance
April 07 2026,10:00pm PDT

Veeva Vault 26R1 Release Notice (Self-Serve Prerelease) - Downtime Required

Status: closed
Start: April 07 2026,4:00pm PDT
End: April 07 2026,10:00pm PDT
Duration: 6 hours
Affected Components:
Veeva Vault Vault-US PODs Vault-EU PODs Vault-AP PODs VV3-3086 VV1-24 VV2-2085 VV1-40 VV1-42 VV2-2130 VV1-1156 VV1-1199
Update

April 07 2026,4:00pm PDT

April 07 2026,4:00pm PDT

Veeva Vault Release Notification

What : Veeva Vault 26R1 Upgrade - Prerelease PODs
Target Date Tuesday, April 7
Target Time: 4:00 pm PDT (April 8 at 1:00 am CEST/8:00 am JST)
Estimated Duration : 2 to 4 hours  
Affected PODs
Prerelease PODs (APAC/EU/US): VV1-24, VV1-40, VV1-42, VV1-1156, VV1-1199, VV2-2085, VV2-2130, VV3-3086   

Changes to the Target Date or Target Time will be posted on the  Veeva Trust Site .  

Click here to learn how to find your Vault's POD location.

26R1 Release Information


The 26R1 Prerelease Program will conclude on  May 18, 2026 .   

For up-to-date information on Veeva Systems' service status, see the Veeva Trust Site .
If you have any further questions, please submit a ticket with Veeva Product Support .   

Resolved

April 07 2026,10:00pm PDT

April 07 2026,10:00pm PDT

Scheduled Maintenance closed.