Veeva Safety Maintenance Release Notification - 26R2.0.5-Downtime required

Maintenance
August 24 2026,7:00pm PDT

Veeva Safety Maintenance Release Notification - 26R2.0.5-Downtime required

Status: closed
Start: August 24 2026,5:00pm PDT
End: August 24 2026,7:00pm PDT
Duration: 2 hours
Affected Components:
Veeva Vault Vault-US PODs Vault-EU PODs VV2-2075 VV1-1067 VV2-2156 VV2-2159 VV2-2160 VV2-2161 VV2-2162 VV1-1138 VV1-1142 VV1-1150 VV1-1157 VV1-1169 VV1-1176 VV1-1181
Update

August 24 2026,5:00pm PDT

August 24 2026,5:00pm PDT

Veeva Safety Maintenance Release Notification


The Veeva Safety Vault is scheduled to be upgraded to the latest maintenance release. 

There is an expected downtime affecting Workbench reports,Signal calculations & workbench Dashboards.This does not affect Safety application .

What: Veeva Safety 26R2.0.5
When: Monday August 24 at 5:00 PM PDT (August 25 at 2:00 AM CEST)
Estimated Duration: 90 minutes
Affected PODs: US/EU PODs

US/EU General Release: VV2-2075, VV2-2156, VV2-2162, VV1-1157, VV1-1067, VV1-1142, VV1-1150, VV1-1169, VV1-1176, VV1-1181, VV2-2063, VV2-2158, VV2-2159, VV2-2160, VV2-2161 

US Prerelease: VV1-1138

The 26R2 Prerelease Program will conclude on September 7, 2026.  

SAF-121208

Read the 26R2 Release Notes for details. 

Click here to learn how to find your Vault's POD location. 
For up-to-date information on Veeva Systems' service status, see Veeva Trust Site.
If you have any further questions, please submit a ticket with Veeva Product Support. 

Resolved

August 24 2026,7:00pm PDT

August 24 2026,7:00pm PDT

Scheduled Maintenance closed.