Veeva CRM Hotfix - Asia Pacific Region

Maintenance
July 23 2026,4:00pm PDT

Veeva CRM Hotfix - Asia Pacific Region

Status: closed
Start: July 23 2026,2:00pm PDT
End: July 23 2026,4:00pm PDT
Duration: 2 hours
Affected Components:
Veeva CRM AP Region CRM-30
Update

July 23 2026,2:00pm PDT

July 23 2026,2:00pm PDT

Veeva CRM Sandbox and Production orgs are being upgraded to the 261.3.205 release for Online, iOS, and Windows Platforms . During this time, email delivery and short URL services may be temporarily unavailable for up to 20 minutes.

View Patch Notes

Resolved

July 23 2026,4:00pm PDT

July 23 2026,4:00pm PDT

Scheduled maintenance closed.