Veeva Vault 26R2 Release Notice (Self-Serve Prerelease) - Downtime Required

Maintenance
July 29 2026,10:00am PDT

Veeva Vault 26R2 Release Notice (Self-Serve Prerelease) - Downtime Required

Status: closed
Start: July 29 2026,5:00am PDT
End: July 29 2026,10:00am PDT
Duration: 5 hours
Affected Components:
Veeva Vault Vault-US PODs Vault-EU PODs Vault-AP PODs VV3-3086 VV1-24 VV2-2085 VV1-40 VV1-42 VV2-2130 VV1-1156 VV1-1199
Update

July 29 2026,5:00am PDT

July 29 2026,5:00am PDT

Veeva Vault Release Notification

What : Veeva Vault 26R2 Upgrade - Prerelease PODs
Target Date Tuesday, July 28
Target Time:    4:00 pm PDT 

Updated Target: Wednesday, July 29 5:00 am PDT (2:00 pm CEST/9:00 pm JST)

Estimated Duration : 2 to 4 hours  
Affected PODs
Prerelease PODs (APAC/EU/US): VV1-24, VV1-40, VV1-42, VV1-1156, VV1-1199, VV2-2085, VV2-2130, VV3-3086   

Changes to the Target Date or Target Time will be posted within this Trust message .  

26R2 Release Information


The 26R2 Prerelease Program will conclude on September 7, 2026 .   

Click here to learn how to find your Vault's POD location.
For up-to-date information on Veeva Systems' service status, see the Veeva Trust Site .
If you have any further questions, please submit a ticket with Veeva Product Support .   

Resolved

July 29 2026,10:00am PDT

July 29 2026,10:00am PDT

Scheduled Maintenance closed.