Veeva 26R2 Limited Release Notification - Downtime Required

Maintenance
July 31 2026,11:00pm PDT

Veeva 26R2 Limited Release Notification - Downtime Required

Status: closed
Start: July 31 2026,1:00pm PDT
End: July 31 2026,11:00pm PDT
Duration: 10 hours
Affected Components:
Veeva Vault Vault-US PODs Vault-EU PODs Vault-AP PODs VV3-3123 VV1-21 VV2-2087 VV1-1135
Update

July 31 2026,1:00pm PDT

July 31 2026,1:00pm PDT

Veeva Release Notification

What: Veeva 26R2 Limited Release Upgrade
When: July 31, 2026 
Estimated Vault Downtime: Up to 4 hours

  • The day and time of deployment is determined by each Veeva product and the location of the POD. 
  • Actively working users are notified within Vault just prior to the expected downtime.

Affected PODs and Time of Deployment

Veeva Vault  EU 2:00 pm PDT (11:00 pm CEST):  VV2-2087
Veeva Vault  US 5:00 pm PDT:  VV1-21, VV1-1135
Veeva Safety  APAC 1:00 pm PDT (August 1 at 5:00 am JST):  VV3-3123
Click here learn how to find your Vault's POD location.
For up-to-date information on Veeva Systems' service status, see the Veeva Trust Site.
If you have any further questions, please submit a ticket with Veeva Product Support. 

26R2 Release Information

  • Visit About the 26R2 Release for important dates, the latest Release Impact Assessment, What's New, and the Latest Announcements.
  • The Releases tab on Veeva Connect has additional resources about key features and data model documentation. Join the Communities and stay informed about new content.
  • If you have a Vault integration or custom code, see the Vault Developer Portal.

Resolved

July 31 2026,11:00pm PDT

July 31 2026,11:00pm PDT

Scheduled Maintenance closed.