Veeva CRM Hotfix - Americas and Europe Region
Maintenance
July 16 2026,4:00pm PDT
Veeva CRM Hotfix - Americas and Europe Region
Status: closed
Start:
July 16 2026,2:00pm PDT
End:
July 16 2026,4:00pm PDT
Duration: 2 hours
Affected Components:
Veeva CRM
Veeva MultiChannel & Integrations
MC-01
MC-20
US Region
EU Region
CRM-20
CRM-03
CRM-04
CRM-05
CRM-06
CRM-08
CRM-10
Update
July 16 2026,2:00pm PDT
July 16 2026,2:00pm PDT
Veeva CRM Sandbox and Production orgs are being upgraded to the 261.3.204 release for Online Platforms. During this time, Approved Notes, Scheduling Jobs, and MyInsights Studio will be temporarily unavailable for up to 1 hour. There also may be a delay in Multichannel activities.
View Patch Notes
Resolved
July 16 2026,4:00pm PDT
July 16 2026,4:00pm PDT
Scheduled Maintenance closed.
© 2026 Veeva Trust Site