Veeva CRM Hotfix - Americas Region

Maintenance
July 15 2026,7:00pm PDT

Veeva CRM Hotfix - Americas Region

Status: closed
Start: July 15 2026,5:00pm PDT
End: July 15 2026,7:00pm PDT
Duration: 2 hours
Affected Components:
Veeva CRM US Region CRM-03 CRM-04 CRM-05 CRM-06 CRM-08 CRM-10
Update

July 15 2026,5:00pm PDT

July 15 2026,5:00pm PDT

Veeva CRM Sandbox and Production orgs are being upgraded to the 261.3.203 release for Online and iOS Platforms. During this time, online access may temporarily be unavailable for up to 1 hour.

View Patch Notes

Resolved

July 15 2026,7:00pm PDT

July 15 2026,7:00pm PDT

Scheduled Maintenance closed.