Service Notice – Quick Counts Temporarily Unavailable (Resolved)
Incident
July 07 2026,10:24am PDT
Service Notice – Quick Counts Temporarily Unavailable (Resolved)
Status: closed
Start:
July 07 2026,5:30am PDT
End:
July 07 2026,10:24am PDT
Duration: 4 hours 54 minutes
Affected Components:
Veeva Compass
Update
July 07 2026,5:30am PDT
July 07 2026,5:30am PDT
Between 8:30 AM and 12:00 PM ET today, Quick Counts were temporarily unavailable in the Compass Portal.
The issue has been resolved and Quick Counts are fully functional.
Resolved
July 07 2026,10:24am PDT
July 07 2026,10:24am PDT
The issue has been resolved and Quick Counts are fully functional.
© 2026 Veeva Trust Site