Veeva Compass Scheduled Maintenance (June 24–29)
Maintenance
in progress
1 day 23 hours 17 minutes
June 24 2026,12:03pm PDT
Veeva Compass Scheduled Maintenance (June 24–29)
Status: in progress
Start:
June 24 2026,12:03pm PDT
Estimated Duration: 7200 minutes
Affected Components:
Veeva Compass
Update
June 24 2026,12:03pm PDT
June 24 2026,12:03pm PDT
Veeva Compass will be conducting planned maintenance starting Thursday June 24th, 2026. The data network will remain fully operational and available, however any new data received will be paused and delivered on Monday June 29th, 2026, when maintenance is complete. Jobs will continue to run as expected through the maintenance window.
© 2026 Veeva Trust Site