Veeva CRM MC Service Degradation on MC-01

Incident
April 21 2026,2:37pm PDT

Veeva CRM MC Service Degradation on MC-01

Status: closed
Start: April 21 2026,9:09am PDT
End: April 21 2026,2:37pm PDT
Duration: 5 hours 28 minutes
Affected Components:
Veeva MultiChannel & Integrations MC-01
Update

April 21 2026,9:09am PDT

April 21 2026,9:09am PDT

The MC-01 issue has reappeared. Admin, Content users, Align integration and Network integration are impacted. Normal CRM user activity should be unaffected. The engineering team is working on a resolution.

Update

April 21 2026,9:52am PDT

April 21 2026,9:52am PDT

MC-01 is running as expected. We will keep this degradation open while we continue investigating and ensure the fix is stable.

Resolved

April 21 2026,2:37pm PDT

April 21 2026,2:37pm PDT

MC-01 is back to full functionality. As the servers recovered, some users may have still experienced intermittent issues.