Veeva CRM MC Service Degradation on MC-01

Incident
April 21 2026,7:05am PDT

Veeva CRM MC Service Degradation on MC-01

Status: closed
Start: April 21 2026,6:13am PDT
End: April 21 2026,7:05am PDT
Duration: 52 minutes
Affected Components:
Veeva MultiChannel & Integrations MC-01
Update

April 21 2026,6:13am PDT

April 21 2026,6:13am PDT

Veeva Technology Team observed a performance degradation issue affecting the MC-01 instance. The issue began at 4:00 AM US/Pacific. During this time, customers may experience intermittent errors or slow performance when accessing the Veeva application.

 

Resolved

April 21 2026,7:05am PDT

April 21 2026,7:05am PDT

The issue has been resolved, and all processes are operating normally. Impact included Admin and Content users using our content tools or integrations, and should not have affected CRM user activity.