Veeva Crossix - Production Release 25R3.3.3

Maintenance
April 20 2026,7:05am PDT

Veeva Crossix - Production Release 25R3.3.3

Status: closed
Start: April 20 2026,6:50am PDT
End: April 20 2026,7:05am PDT
Duration: 15 minutes
Affected Components:
Veeva Crossix
Update

April 20 2026,6:50am PDT

April 20 2026,6:50am PDT

There is a production release scheduled for Veeva Crossix  25R3.3.3 on  04/20/2026 06:50 AM PT . 
The approximate duration of the release will be 60 minutes during which the Crossix Measurement Suite and Crossix Data Stream may be unavailable.

Resolved

April 20 2026,7:05am PDT

April 20 2026,7:05am PDT

Done