Veeva Compass 25R3.6 Release
Maintenance
March 23 2026,4:00pm PDT
Veeva Compass 25R3.6 Release
Status: closed
Start:
March 23 2026,3:00pm PDT
End:
March 23 2026,4:00pm PDT
Duration: 1 hour
Affected Components:
Veeva Compass
Update
March 23 2026,3:00pm PDT
March 23 2026,3:00pm PDT
Veeva Compass Release Notification
What: Veeva Compass 25R3.6 Release
When: Monday, March 23rd, 2026 6PM - 7PM EST
Estimated Downtime: 60 minutes
For more information on this 25R3.6 release:
Visit Veeva Compass Help for the Release Notes, if applicable
Join the Veeva Compass Connect Community and stay informed when new content is added
Resolved
March 23 2026,4:00pm PDT
March 23 2026,4:00pm PDT
Scheduled Maintenance closed.
© 2026 Veeva Trust Site