Veeva CRM - Salesforce Disruption affecting online access

Incident
March 17 2026,12:07am PDT

Veeva CRM - Salesforce Disruption affecting online access

Status: closed
Start: March 16 2026,9:32pm PDT
End: March 17 2026,12:07am PDT
Duration: 2 hours 35 minutes
Affected Components:
Veeva CRM US Region EU Region AP Region CRM-20 CRM-30 CRM-03 CRM-04 CRM-05 CRM-06 CRM-08 CRM-10
Update

March 16 2026,9:32pm PDT

March 16 2026,9:32pm PDT

Salesforce is currently experiencing an outage affecting Veeva CRM. Users attempting to login will experience login failures with an internal server error. Offline mode on iOS will still allow for the creation of calls and displaying media, however, sync and online functionality is not available.

For the latest information, please follow Salesforce's incident at https://status.salesforce.com/incidents/20003819

Update

March 16 2026,11:09pm PDT

March 16 2026,11:09pm PDT

Salesforce has identified the issue and are actively deploying a fix across the remaining impacted instances to restore services.

Resolved

March 17 2026,12:07am PDT

March 17 2026,12:07am PDT

Salesforce has confirmed the incident is resolved and updated the impact. Upon review, they found that only a few of their PODs were affected, impacting a small number of Veeva CRM customers.