Veeva Compass Scheduled Maintenance
Maintenance
February 26 2026,6:43pm PST
Veeva Compass Scheduled Maintenance
Status: closed
Start:
February 26 2026,6:00pm PST
End:
February 26 2026,6:43pm PST
Duration: 43 minutes
Affected Components:
Veeva Compass
Update
February 26 2026,6:00pm PST
February 26 2026,6:00pm PST
The scheduled EKS cluster maintenance is planned for February 26, 2026 at 6:00 PM PT and may temporarily impact Veeva Compass Portal and SFTP availability.
Resolved
February 26 2026,6:43pm PST
February 26 2026,6:43pm PST
Scheduled Maintenance closed.
© 2026 Veeva Trust Site