Veeva Basics Maintenance Release Notification

Maintenance
February 11 2026,7:00pm PST

Veeva Basics Maintenance Release Notification

Status: closed
Start: February 11 2026,6:00pm PST
End: February 11 2026,7:00pm PST
Duration: 1 hour
Affected Components:
Veeva Vault Vault-US PODs Vault-EU PODs VV2-2151 VV1-1186 VV1-1201
Update

February 11 2026,6:00pm PST

February 11 2026,6:00pm PST

Veeva Basics Maintenance Release Notification

 
Veeva  Quality Basics   will be upgraded to the latest maintenance release and system will be unavailable for use during this time.
 
WhatVeeva Basics 25R3.0.62
When: Wednesday February 11, 6:00 PM PT
Estimated Vault Downtime (only for Quality Vaults) :  Up to 60 minutes

Read the  Veeva Basics Maintenance Release Notes  for additional details. For  up-to-date information on Veeva Systems' service status, see the  Veeva Trust Site . If you have any further questions, dedicated Support is available at:
☎️ +1 (800) 971-3716
✉️ qualitybasics.support@veeva.com
✉️ rimbasics.support@veeva.com
✉️ clinicalbasics.support@veeva.com
✉️ promomatsbasics.support@veeva.com
✉️ limsbasics.support@veeva.com

Resolved

February 11 2026,7:00pm PST

February 11 2026,7:00pm PST

Maintenance Release Completed