Delay in Veeva Compass Daily Job Processing

Incident
January 26 2026,2:14pm PST

Delay in Veeva Compass Daily Job Processing

Status: closed
Start: January 26 2026,5:57am PST
End: January 26 2026,2:14pm PST
Duration: 8 hours 17 minutes
Affected Components:
Veeva Compass
Update

January 26 2026,5:57am PST

January 26 2026,5:57am PST

Veeva Compass is currently experiencing a delay in today’s daily job processing. As a result, customer jobs will run later than their scheduled start times. New network data additions and Veeva Payer data will be delayed in launch. Veeva Engineering teams are actively working to restore normal processing. Customers will be notified once daily jobs are initiated, and a follow-up update will be provided after processing has stabilized. 

Resolved

January 26 2026,2:14pm PST

January 26 2026,2:14pm PST

The impacted Veeva Compass daily jobs have now resumed. All delayed daily jobs have now been have started, and processing has returned to normal. 

The communicated network data additions and Veeva Payer Data has also been successfully launched in the data network.