Veeva CRM Maintenance Release - Europe Region
Maintenance
January 15 2026,4:00pm PST
Veeva CRM Maintenance Release - Europe Region
Status: closed
Start:
January 15 2026,2:00pm PST
End:
January 15 2026,4:00pm PST
Duration: 2 hours
Affected Components:
Veeva CRM
Veeva MultiChannel & Integrations
MC-01
MC-20
EU Region
ENGAGE-01
CRM-20
Update
January 15 2026,2:00pm PST
January 15 2026,2:00pm PST
Veeva CRM Sandbox and Production orgs will be upgraded to the 253.0.500 release for Online and Windows platforms. Systems are generally available during this time.
View Patch Notes
Resolved
January 15 2026,4:00pm PST
January 15 2026,4:00pm PST
Scheduled Maintenance closed.
© 2026 Veeva Trust Site