Veeva 25R3 Release Notice (Self-Serve Prerelease) - Downtime Required

Maintenance
November 21 2025,3:48pm PST

Veeva 25R3 Release Notice (Self-Serve Prerelease) - Downtime Required

Status: closed
Start: November 21 2025,1:00pm PST
End: November 21 2025,3:48pm PST
Duration: 2 hours 48 minutes
Affected Components:
Veeva Vault Vault-US PODs Vault-AP PODs VV3-3124 VV1-1137 VV1-1138 VV1-1197
Update

November 21 2025,1:00pm PST

November 21 2025,1:00pm PST

Veeva Release Notification

What : Veeva 25R3 Upgrade - Prerelease PODs 
When : November 21, 2025 
Estimated Vault Downtime : 10 minutes

  • The upgrade is expected to take approximately 10 minutes, during which time your Vault will not be available for use.
  • The day and time of deployment is determined by each Veeva product and the location of the POD as noted below. 
  • Users can continue working as normal and will be notified within Vault just prior to the expected downtime.

Affected PODs and Time of Deployment

Veeva Safety   US/APAC  1:00 pm PST (Saturday, November 22, 6:00 am JST):   VV1-1138 VV3-3124
Veeva RegulatoryOne   US  6:00 pm PST :  See Trust for latest status
VV1-1137
Veeva LIMS   US  7:00 pm PST :  See Trust for latest status
VV1-1197

25R3 Release Information


The 25R3 Prerelease Program will conclude on  January 12, 2026 .

For up-to-date information on Veeva Systems' service status, see the Veeva Trust Site .
If you have any further questions, please submit a ticket with Veeva Product Support .

Resolved

November 21 2025,3:48pm PST

November 21 2025,3:48pm PST

.