Veeva 25R3 Release Notification (APAC/EU/US) – Downtime Required

Maintenance
December 06 2025,2:00am PST

Veeva 25R3 Release Notification (APAC/EU/US) – Downtime Required

Status: closed
Start: December 05 2025,1:00pm PST
End: December 06 2025,2:00am PST
Duration: 13 hours
Affected Components:
Veeva Vault Vault-US PODs Vault-EU PODs Vault-AP PODs VV3-3120 VV2-2063 VV3-3131 VV2-2121 VV1-1061 VV1-1067 VV2-2153 VV2-2156 VV1-1142 VV1-1150 VV1-1169 VV1-1173 VV1-1176 VV1-1181 VV1-1202 VV1-1211
Update

December 05 2025,1:00pm PST

December 05 2025,1:00pm PST

Veeva Release Notification

What: Veeva 25R3 General Release
When: December 5, 2025
Estimated Vault Downtime: 10 minutes

  • The upgrade is expected to take approximately 10 minutes, during which time your Vault will not be available for use.
  • The day and time of deployment is determined by each Veeva product and the location of the POD as noted below.
  • Users can continue working as normal and will be notified within Vault just prior to the expected downtime.

Affected PODs and Time of Deployment

Veeva Safety between 1:00 pm and 3:00 pm PST/10:00 pm and midnight CET (December 6, between 6:00 and 8:00 am JST): 
VV2-2156, VV3-3120, VV3-3131
Veeva Safety between 7:30 pm and 9:30 pm PST (December 6, between 4:30 and 6:30 am CET): 
VV1-1067, VV1-1142, VV1-1150, VV1-1169, VV1-1176, VV1-1181, VV2-2063
Veeva RegulatoryOne between 8:30 pm and 10:30 pm PST (December 6, between 5:30 and 7:30 am CET):  
VV1-1061, VV1-1202, VV2-2121, VV2-2153
Veeva LIMS between 10:00 pm and midnight PST:
VV1-1173, VV1-1211
For up-to-date information on Veeva Systems' service status, see the Veeva Trust Site.
If you have any further questions, please submit a ticket with Veeva Product Support. 

25R3 Release Information

Resolved

December 06 2025,2:00am PST

December 06 2025,2:00am PST

Scheduled Maintenance closed.