Veeva 25R3 Release Notice (APAC/EU/US Sandbox) – Downtime Required

Maintenance
December 06 2025,1:30am PST

Veeva 25R3 Release Notice (APAC/EU/US Sandbox) – Downtime Required

Status: closed
Start: December 05 2025,10:00am PST
End: December 06 2025,1:30am PST
Duration: 15 hours 30 minutes
Affected Components:
Veeva Vault Vault-US PODs Vault-EU PODs Vault-AP PODs VV3-3057 VV3-3099 VV2-2056 VV3-3125 VV1-18 VV2-2070 VV2-2072 VV2-2075 VV2-2080 VV2-2083 VV3-3132 VV2-2098 VV1-43 VV2-2120 VV2-2125 VV2-2126 VV1-1055 VV1-1058 VV1-1066 VV1-1068 VV1-1073 VV1-1074 VV2-2139 VV1-1076 VV2-2140 VV1-1077 VV1-1079 VV1-1081 VV2-2148 VV1-1089 VV2-2150 VV1-1121 VV1-1122 VV1-1126 VV1-1128 VV1-1132 VV1-1136 VV1-1145 VV1-1153 VV1-1155 VV1-1157 VV1-1170 VV1-1171 VV1-1200 VV1-1205
Update

December 05 2025,10:00am PST

December 05 2025,10:00am PST

Veeva Release Notification

What: Veeva 25R3 General Release
When: December 5, 2025
Estimated Duration: 2 to 4 hours

  • The day and time of deployment is determined by each Veeva product and the location of the POD as noted below. 
  • Users can continue working as normal and will be notified within Vault just prior to the expected downtime.
  • Veeva Vault includes Vault Platform + embedded applications (Quality, Clinical Operations, PromoMats, MedComms, and RIM suite).

Affected PODs and Time of Deployment

Veeva Vault  APAC 10:00 am PST (December 6, 3:00 am JST): 
VV3-3057, VV3-3099, VV3-3125, VV3-3132
Veeva Vault  EU 10:00 am PST (7:00 pm CET): 
VV2-2056, VV2-2070, VV2-2072, VV2-2080, VV2-2083, VV2-2098, VV2-2120, VV2-2125, VV2-2126, VV2-2139, VV2-2140, VV2-2148, VV2-2150  
Veeva Vault  US 2:00 pm PST
VV1-1055VV1-1058, VV1-1066, VV1-1068, VV1-1073, VV1-1074, VV1-1076, VV1-1077, VV1-1079, VV1-1081, VV1-1089, VV1-1121VV1-1122, VV1-1126, VV1-1128, VV1-1132, VV1-1136, VV1-1145, VV1-1153, VV1-1155, VV1-1170, VV1-1171, VV1-1200, VV1-1205, VV1-18, VV1-43
Veeva Safety  EU 1:00 pm PST (10:00 pm CET):  
VV2-2075
Veeva Safety  US 7:30 pm PST:  
VV1-1157
For up-to-date information on Veeva Systems' service status, see the Veeva Trust Site.
If you have any further questions, please submit a ticket with Veeva Product Support. 

25R3 Release Information

Resolved

December 06 2025,1:30am PST

December 06 2025,1:30am PST

Scheduled Maintenance closed.