Crossix Measurement Suite - Intermittent Service Disruption

Incident
November 04 2025,9:02am PST

Crossix Measurement Suite - Intermittent Service Disruption

Status: closed
Start: November 03 2025,7:13am PST
End: November 04 2025,9:02am PST
Duration: 1 day 1 hour 49 minutes
Affected Components:
Veeva Crossix
Update

November 03 2025,7:13am PST

November 03 2025,7:13am PST

The Crossix Measurement Suite is experiencing an intermittent service disruption where the user interface may be unreachable for certain users. Veeva Engineering teams are investigating the issue. If you are impacted by this disruption and require assistance please try updating your browser to the latest version and contact crossix_support@veeva.com for further assistance.

Update

November 03 2025,2:34pm PST

November 03 2025,2:34pm PST

Veeva Engineering teams are continuing to investigate the login page issue for certain users. For users still impacted by this, the below troubleshooting actions may resolve the issue:

1. Clearing your browser cache (see instructions here for your specific browser).

2. Ensuring your browser is updated to the latest version.

If you continue to be impacted by the disruption and require further assistance please contact crossix_support@veeva.com.

Resolved

November 04 2025,9:02am PST

November 04 2025,9:02am PST

Veeva Engineering teams have resolved the issue with the blank login screen impacting a few users. If you continue to experience an issue accessing veevacrossix.com please try and clear your browser cache.

For any further troubleshooting please contact crossix_support@veeva.com.