Veeva 25R3 Release Notice (Early SBX and Veeva Internal PODs) - Downtime Required

Maintenance
November 21 2025,3:10pm PST

Veeva 25R3 Release Notice (Early SBX and Veeva Internal PODs) - Downtime Required

Status: closed
Start: November 21 2025,1:00pm PST
End: November 21 2025,3:10pm PST
Duration: 2 hours 10 minutes
Affected Components:
Veeva Vault Vault-US PODs Vault-EU PODs VV2-2122 VV1-1054 VV1-1069 VV1-1140 VV1-1144 VV1-1206
Update

November 21 2025,1:00pm PST

November 21 2025,1:00pm PST

Veeva Release Notification

What: Veeva 25R3 General Release 
When: Friday, November 21
Estimated Duration2 to 4 hours 

  • The day and time of deployment are determined by each Veeva product and the location of the POD as noted below. 
  • Users can continue working as normal and will be notified within Vault just prior to the expected downtime.
  • Veeva Vault includes Vault Platform + embedded applications (Quality, Clinical Operations, PromoMats, MedComms, and RIM suite)

Affected PODs and Time of Deployment

Veeva Vault  EU 2:00 pm PST (11:00 pm CET):  VV2-2122
Veeva Vault  US 2:00 pm PST:  VV1-1054, VV1-1069, VV1-1140, VV1-1144
Veeva Safety  US 1:00 pm PST:  VV1-1206
  • Click here to learn how to find your Vault's POD location. 
  • For up-to-date information on Veeva Systems' service status, see the Veeva Trust Site.
  • If you have any further questions, please submit a ticket with Veeva Product Support. 

25R3 Release Information

Visit About the 25R3 Release for details about the upcoming general release, including the RIA and the Latest Announcements.  

Resolved

November 21 2025,3:10pm PST

November 21 2025,3:10pm PST

Maintenance has ended.