Performance Degradation affecting all Customer Jobs
Incident
October 20 2025,3:53pm PDT
Performance Degradation affecting all Customer Jobs
Status: closed
Start:
October 20 2025,6:29am PDT
End:
October 20 2025,3:53pm PDT
Duration: 9 hours 24 minutes
Affected Components:
Veeva Compass
Update
October 20 2025,6:29am PDT
October 20 2025,6:29am PDT
AWS is experiencing increased error rates and latency. As a result Veeva Compass is currently experiencing intermittent degraded performance.
More info from Amazon here: https://health.aws.amazon.com/health/status
Resolved
October 20 2025,3:53pm PDT
October 20 2025,3:53pm PDT
Veeva Compass is now fully available with all services operating normally.
© 2025 Veeva Trust Site