Veeva Crossix - Service Disruption
Incident
October 20 2025,3:29am PDT
Veeva Crossix - Service Disruption
Status: closed
Start:
October 20 2025,2:09am PDT
End:
October 20 2025,3:29am PDT
Duration: 1 hour 20 minutes
Affected Components:
Veeva Crossix
Update
October 20 2025,2:09am PDT
October 20 2025,2:09am PDT
Veeva Crossix is experiencing intermittent performance degradation and service disruption due to a global AWS outage.
Resolved
October 20 2025,3:29am PDT
October 20 2025,3:29am PDT
Service is now restored and Veeva Crossix is now fully available.
© 2025 Veeva Trust Site