RTSM Login Issue

Incident
October 08 2025,10:56am PDT

RTSM Login Issue

Status: closed
Start: October 08 2025,9:30am PDT
End: October 08 2025,10:56am PDT
Duration: 1 hour 26 minutes
Affected Components:
Veeva RTSM
Update

October 08 2025,9:30am PDT

October 08 2025,9:30am PDT

Please be advised that Veeva RTSM experienced a temporary issue which impacted a small number of customers ability to login. During this time, users may have encountered intermittent access issues.

Our RTSM Systems Administrator promptly investigated the issue and restored the service.

If you have any questions or need assistance, please don’t hesitate to contact our Help Desk for support.

https://support.veeva.com/hc/en-us/articles/11939522879643-Veeva-RTSM-Global-Service-Center-Contact-Directory

 

 Thank you for your understanding.

Resolved

October 08 2025,10:56am PDT

October 08 2025,10:56am PDT

All services operating normally.