Crossix Service Disruption - Crossix Data Stream

Incident
September 08 2025,9:15am PDT

Crossix Service Disruption - Crossix Data Stream

Status: closed
Start: September 05 2025,11:56am PDT
End: September 08 2025,9:15am PDT
Duration: 2 days 21 hours 19 minutes
Affected Components:
Veeva Crossix
Update

September 05 2025,11:56am PDT

September 05 2025,11:56am PDT

The Crossix Measurement Suite is currently experiencing a service disruption with data stream. Veeva engineering teams are working to restore the service as quickly as possible. This does not impact results delivered through the interface or audience segments.

We will post an update by 12PM EST on 9/8

Resolved

September 08 2025,9:15am PDT

September 08 2025,9:15am PDT

Veeva engineering has identified the problem and has restored the service of the Crossix Data Stream. Data Stream publication will resume normally with this week's publication.