eCOA Vault 25R2.2 Limited Release Upgrade
Maintenance
August 22 2025,1:00pm PDT
eCOA Vault 25R2.2 Limited Release Upgrade
Status: closed
Start:
August 22 2025,11:00am PDT
End:
August 22 2025,1:00pm PDT
Duration: 2 hours
Affected Components:
eCOA Vault
eCOA Vault-US
VV1-1179
Update
August 22 2025,11:00am PDT
August 22 2025,11:00am PDT
eCOA Vault Release Notification
What: eCOA Vault 25R2.2 Limited Release Upgrade
Estimated Duration: 1 to 2 hours
Affected POD: Limited Release POD (VV1-1179)
The upgrade is expected to take approximately 10 minutes, during which time your limited release eCOA Vault will be unavailable for use. Users can continue to work as normal and will be notified in eCOA just before the expected downtime.
What’s New:
The What's New is planned to be available on the day of the release and will contain in-depth information about the new features in 25R2.2.
Support:
- See Vault POD Details to learn how to find your Vault’s POD location.
- See the Veeva Trust Site for updates regarding system availability. eCOA Vault availability is reported under eCOA Vault, and MyVeeva availability under MyVeeva (eCOA, eConsent).
- If you have additional questions, please submit a ticket to Veeva Product Support.
Resolved
August 22 2025,1:00pm PDT
August 22 2025,1:00pm PDT
Scheduled Maintenance closed.
© 2025 Veeva Trust Site