Veeva 25R2 Release Notice (Self-Serve Prerelease) - Downtime Required

Maintenance
July 25 2025,11:00pm PDT

Veeva 25R2 Release Notice (Self-Serve Prerelease) - Downtime Required

Status: closed
Start: July 25 2025,1:00pm PDT
End: July 25 2025,11:00pm PDT
Duration: 10 hours
Affected Components:
Veeva Vault Vault-US PODs Vault-AP PODs VV3-3124 VV1-1137 VV1-1138 VV1-1197
Update

July 25 2025,1:00pm PDT

July 25 2025,1:00pm PDT

Veeva Release Notification

What: Veeva 25R2 Upgrade - Prerelease PODs
When: July 25, 2025 
Estimated Vault Downtime: 10 minutes

  • The upgrade is expected to take approximately 10 minutes, during which time your Vault will not be available for use. 
  • The day and time of deployment is determined by each Veeva product and the location of the POD as noted below. 
  • Users can continue working as normal and will be notified within Vault just prior to the expected downtime.

Affected PODs and Time of Deployment

Veeva Safety  US/APAC 1:00 pm PDT (Saturday, July 26, 5:00 am JST):  VV1-1138VV3-3124
Veeva RegulatoryOne  US 6:00 pm PDT:  VV1-1137
Veeva LIMS  US 7:00 pm PDT:  VV1-1197

25R2 Release Information

Click here to learn how to find your Vault's POD location.
For up-to-date information on Veeva Systems' service status, see the Veeva Trust Site.
If you have any further questions, please submit a ticket with Veeva Product Support. 

Resolved

July 25 2025,11:00pm PDT

July 25 2025,11:00pm PDT

Scheduled Maintenance closed.