Veeva 25R2 Release Notification (VV1-1068 and Veeva Internal) - Downtime Required
Maintenance
July 25 2025,8:00pm PDT
Veeva 25R2 Release Notification (VV1-1068 and Veeva Internal) - Downtime Required
Status: closed
Start:
July 25 2025,1:00pm PDT
End:
July 25 2025,8:00pm PDT
Duration: 7 hours
Affected Components:
Veeva Vault
Vault-US PODs
Vault-EU PODs
VV2-2122
VV1-1054
VV1-1068
VV1-1140
VV1-1206
Update
July 25 2025,1:00pm PDT
July 25 2025,1:00pm PDT
Veeva Release NotificationWhat: Veeva 25R2 General Release When: Friday, July 25, 2025 Estimated Duration: 2 to 4 hours
|
Affected PODs and Time of Deployment |
Veeva Vault EU 2:00 pm PDT (11:00 pm CEST): VV2-2122 |
Veeva Safety US 1:00 pm PDT: VV1-1206 |
|
25R2 Release InformationVisit About the 25R2 Release for details about the upcoming general release, including the Latest Announcements. Beginning with 25R2 and for all subsequent releases, Veeva LIMS, Veeva Safety, and Veeva RegulatoryOne & Veeva Claims release on the same date as the Veeva Vault Platform. |
Resolved
July 25 2025,8:00pm PDT
July 25 2025,8:00pm PDT
Scheduled Maintenance closed.
© 2026 Veeva Trust Site