Veeva CRM Hotfix - Americas Region
Maintenance
June 17 2025,7:00pm PDT
Veeva CRM Hotfix - Americas Region
Status: closed
Start:
June 17 2025,5:00pm PDT
End:
June 17 2025,7:00pm PDT
Duration: 2 hours
Affected Components:
Veeva CRM
US Region
CRM-03
CRM-04
CRM-05
CRM-06
CRM-08
CRM-10
Update
June 17 2025,5:00pm PDT
June 17 2025,5:00pm PDT
Veeva CRM Sandbox and Production orgs are being upgraded to the 251.2.301 release for Online Platforms. Systems are generally available during this time.
View Patch Notes
Resolved
June 17 2025,7:00pm PDT
June 17 2025,7:00pm PDT
Scheduled Maintenance closed.
© 2024 Veeva Trust Site