Veeva CRM Maintenance Release - all regions
Maintenance
May 08 2025,6:00pm PDT
Veeva CRM Maintenance Release - all regions
Status: closed
Start:
May 08 2025,2:00pm PDT
End:
May 08 2025,6:00pm PDT
Duration: 4 hours
Affected Components:
Veeva CRM
Veeva MultiChannel & Integrations
MC-01
MC-20
US Region
EU Region
MC-30
AP Region
CRM-20
CRM-30
CRM-03
CRM-04
CRM-05
CRM-06
CRM-08
CRM-10
Update
May 08 2025,2:00pm PDT
May 08 2025,2:00pm PDT
Veeva CRM Sandbox and Production orgs will be upgraded to the 251.0.300 release for iOS platforms. CRM systems are generally available during this time, but Compass Data Engine may be unavailable.
View Patch Notes
Resolved
May 08 2025,6:00pm PDT
May 08 2025,6:00pm PDT
Scheduled Maintenance closed.
© 2025 Veeva Trust Site