Veeva Crossix - Production Release 25R1

Maintenance
May 06 2025,12:39am PDT

Veeva Crossix - Production Release 25R1

Status: closed
Start: April 29 2025,10:30pm PDT
End: May 06 2025,12:39am PDT
Duration: 6 days 2 hours 9 minutes
Affected Components:
Veeva Crossix
Update

April 29 2025,10:30pm PDT

April 29 2025,10:30pm PDT

There is a production release scheduled for Veeva Crossix 25R1 on 04/29/2025 10:30 PM PT.
The approximate duration of the release will be 60 minutes during which the Crossix Measurement Suite and Crossix Data Stream may be unavailable.

Resolved

May 06 2025,12:39am PDT

May 06 2025,12:39am PDT

Done