Veeva Engage Meeting - Admin Group Management Unavailable

Incident
April 28 2025,4:19am PDT

Veeva Engage Meeting - Admin Group Management Unavailable

Status: closed
Start: April 27 2025,6:30pm PDT
End: April 28 2025,4:19am PDT
Duration: 9 hours 49 minutes
Affected Components:
Veeva MultiChannel & Integrations ENGAGE-01
Update

April 27 2025,6:30pm PDT

April 27 2025,6:30pm PDT

Veeva Engage Meeting Service is currently unavailable. Veeva Technology Team is investigating the issue and will provide updates as they become available.

UPDATE: After further review, Veeva Engage Meeting Service is currently available. The only impacted area is management of Engage Groups. Admins cannot add or remove users to Engage Groups at this time.

Update

April 27 2025,9:13pm PDT

April 27 2025,9:13pm PDT

After further review, Veeva Engage Meeting Service is currently available. The only impacted area is management of Engage Groups. Admins cannot add or remove users to Engage Groups at this time.

Veeva Technology Team is investigating the issue and will provide updates as they become available.

Resolved

April 28 2025,4:19am PDT

April 28 2025,4:19am PDT

Veeva Engage admin functionality is now fully available with all services operating normally.