eCOA Vault 25R1.2 Limited Release Notification - Downtime Required
Maintenance
April 25 2025,1:00pm PDT
eCOA Vault 25R1.2 Limited Release Notification - Downtime Required
Status: closed
Start:
April 25 2025,11:00am PDT
End:
April 25 2025,1:00pm PDT
Duration: 2 hours
Affected Components:
eCOA Vault
eCOA Vault-US
VV1-1179
Update
April 25 2025,11:00am PDT
April 25 2025,11:00am PDT
eCOA Vault Release Notification
What: eCOA Vault 25R1.2 Limited Release Upgrade
Estimated Duration: 1 to 2 hours
Affected POD: Limited Release POD (VV1-1179)
The upgrade is expected to take approximately 10 minutes, during which time your limited release eCOA Vault will be unavailable for use. Users can continue to work as normal and will be notified in eCOA Vault just before the expected downtime.
Help & Support
- Read What's New to learn about the new features in the limited release.
- See Vault POD Details to learn how to find your Vault’s POD location.
- See the Veeva Trust Site for updates regarding system availability. eCOA Vault availability is reported under eCOA Vault, and MyVeeva availability under MyVeeva (eCOA, eConsent).
Resolved
April 25 2025,1:00pm PDT
April 25 2025,1:00pm PDT
Scheduled Maintenance closed.
© 2025 Veeva Trust Site