Veeva CRM Major Release - Production - Americas Region

Maintenance
May 02 2025,12:00am PDT

Veeva CRM Major Release - Production - Americas Region

Status: closed
Start: May 01 2025,5:00pm PDT
End: May 02 2025,12:00am PDT
Duration: 7 hours
Affected Components:
Veeva CRM US Region CRM-03 CRM-04 CRM-05 CRM-06 CRM-08 CRM-10
Update

May 01 2025,5:00pm PDT

May 01 2025,5:00pm PDT

Veeva CRM Production and Sandbox orgs will be upgraded to the 25R1.0 Major Release. Systems are generally available during this time.


View Release Notes

Update

May 01 2025,7:45pm PDT

May 01 2025,7:45pm PDT

Update: During the second half of the release window, users may not have access to Veeva CRM online. Veeva CRM on Mobile devices will work in offline mode during this time.

Update

May 01 2025,8:27pm PDT

May 01 2025,8:27pm PDT

Extending the maintenance window to midnight. The release team is working on finalizing the release. During this time, users may not have access to Veeva CRM online. Veeva CRM on Mobile devices will work in offline mode.

Resolved

May 02 2025,12:00am PDT

May 02 2025,12:00am PDT

Scheduled Maintenance closed.