Veeva CRM Server Maintenance

Maintenance
April 10 2025,4:00pm PDT

Veeva CRM Server Maintenance

Status: closed
Start: April 10 2025,2:00pm PDT
End: April 10 2025,4:00pm PDT
Duration: 2 hours
Affected Components:
Veeva MultiChannel & Integrations MC-20 ENGAGE-01
Update

April 10 2025,2:00pm PDT

April 10 2025,2:00pm PDT

Veeva CRM will be undergoing server maintenance. During this time, Multichannel and Engage activities will be temporarily unavailable.

Resolved

April 10 2025,4:00pm PDT

April 10 2025,4:00pm PDT

Scheduled Maintenance closed.