Veeva CRM Server Maintenance - Americas Region
Maintenance
April 03 2025,8:00pm PDT
Veeva CRM Server Maintenance - Americas Region
Status: closed
Start:
April 03 2025,5:00pm PDT
End:
April 03 2025,8:00pm PDT
Duration: 3 hours
Affected Components:
Veeva MultiChannel & Integrations
MC-01
Update
April 03 2025,5:00pm PDT
April 03 2025,5:00pm PDT
Update: Maintenance has been moved to 5pm PT.
Veeva CRM will be undergoing server maintenance. During this time, Multichannel functionalities—including features within Approved Email and CLM—will be temporarily unavailable.
Resolved
April 03 2025,8:00pm PDT
April 03 2025,8:00pm PDT
Scheduled Maintenance closed.
© 2024 Veeva Trust Site