Engage HCP - Unable to Join Meeting on Android
Incident
March 21 2025,10:43pm PDT
Engage HCP - Unable to Join Meeting on Android
Status: closed
Start:
March 21 2025,1:18pm PDT
End:
March 21 2025,10:43pm PDT
Duration: 9 hours 25 minutes
Affected Components:
Veeva MultiChannel & Integrations
ENGAGE-01
Update
March 21 2025,1:18pm PDT
March 21 2025,1:18pm PDT
HCPs are currently unable to join an Engage meeting using the Android app. The CRM team is investigating the issue.
As a workaround, HCPs can join via a mobile browser
Resolved
March 21 2025,10:43pm PDT
March 21 2025,10:43pm PDT
A new version of the Android HCP app is now available which resolves the issue.
© 2024 Veeva Trust Site