Veeva EDC 25R1.0 Release Notification -Downtime Required
Maintenance
April 02 2025,5:00pm PDT
Veeva EDC 25R1.0 Release Notification -Downtime Required
Status: closed
Start:
April 02 2025,3:00pm PDT
End:
April 02 2025,5:00pm PDT
Duration: 2 hours
Affected Components:
Veeva CDMS
CDMS-US
CDMS-EU
VV2-2152
VV1-37
Update
April 02 2025,3:00pm PDT
April 02 2025,3:00pm PDT
The Veeva EDC service is scheduled to be upgraded. Veeva EDC service will not be available during this time.
What: Veeva EDC 25R1.0 Limited Release
When: Wednesday, April 02 at 3:00 PM PT
Estimated Duration: 2 hours
Affected PODs: VV1-37, VV2-2152
For more details, please read the Release Notes to learn more about the new features.
Resolved
April 02 2025,5:00pm PDT
April 02 2025,5:00pm PDT
Scheduled Maintenance closed.
© 2024 Veeva Trust Site