eCOA Vault 25R1 Release Notice (Self-Serve Pre-Release) - Downtime Required
Maintenance
April 02 2025,1:00pm PDT
eCOA Vault 25R1 Release Notice (Self-Serve Pre-Release) - Downtime Required
Status: closed
Start:
April 02 2025,10:00am PDT
End:
April 02 2025,1:00pm PDT
Duration: 3 hours
Affected Components:
eCOA Vault
eCOA Vault-US
VV1-1182
Update
April 02 2025,10:00am PDT
April 02 2025,10:00am PDT
eCOA Vault Release Notification
What: eCOA Vault 25R1 Pre-Release Upgrade
Estimated Duration: 1 to 3 hours
Affected POD: Pre-Release POD (VV1-1182)
The upgrade is expected to take approximately 10 minutes, during which time your pre-release eCOA Vault will be unavailable for use. Users can continue to work as normal and will be notified in eCOA Vault just before the expected downtime.
The 25R1 Vault self-serve pre-release functionality was enabled for all production eCOA Vaults (PODs VV1-1188, VV2-2144, VV3-3130) on March 17, 2025. If you don't have a production Vault, pre-release capability was enabled on your sandbox Vault (POD VV1-1182). The 25R1 Pre-Release Program will conclude on May 12, 2025.
What’s New:
- See About the Release for release details and the impact assessment.
- Read What's New for in-depth information about the new features.
- The Releases tab on Veeva Connect has additional resources about key features in this release. Join the eCOA community to stay informed.
Support:
- See Pre-Release FAQ for information about the pre-release program.
- See Vault POD Details to learn how to find your Vault’s POD location.
- See the Veeva Trust Site for updates regarding system availability. eCOA Vault availability is reported under eCOA Vault, and MyVeeva availability under MyVeeva (eCOA, eConsent).
Resolved
April 02 2025,1:00pm PDT
April 02 2025,1:00pm PDT
Scheduled Maintenance closed.
© 2024 Veeva Trust Site