Veeva CRM Minor Release - Production - Asia Pacific Region
Maintenance
March 20 2025,1:00pm PDT
Veeva CRM Minor Release - Production - Asia Pacific Region
Status: closed
Start:
March 20 2025,10:00am PDT
End:
March 20 2025,1:00pm PDT
Duration: 3 hours
Affected Components:
Veeva CRM
Veeva MultiChannel & Integrations
MC-30
AP Region
CRM-30
Update
March 20 2025,10:00am PDT
March 20 2025,10:00am PDT
Veeva CRM Production and Sandbox orgs will be upgraded to the 24R3.5 Minor Release. Systems are generally available during this time.
Resolved
March 20 2025,1:00pm PDT
March 20 2025,1:00pm PDT
Scheduled Maintenance closed.
© 2024 Veeva Trust Site