Veeva Align Production Release - Americas Region
Maintenance
March 20 2025,9:30pm PDT
Veeva Align Production Release - Americas Region
Status: closed
Start:
March 20 2025,5:30pm PDT
End:
March 20 2025,9:30pm PDT
Duration: 4 hours
Affected Components:
Veeva Align
VA-US
VA-US-2
VA-US-3
VA-US-SBX
Update
March 20 2025,5:30pm PDT
March 20 2025,5:30pm PDT
Update: Deployment will now start at 5:30pm PT
Veeva Align production and sandbox instances will be upgraded to the 24R3.5 Align release. Veeva Align environments will not be available during this time and running processes may be interrupted.
Resolved
March 20 2025,9:30pm PDT
March 20 2025,9:30pm PDT
Scheduled Maintenance closed.
© 2024 Veeva Trust Site