Veeva Align Sandbox Release - Asia and Europe Regions

Maintenance
March 13 2025,2:00pm PDT

Veeva Align Sandbox Release - Asia and Europe Regions

Status: closed
Start: March 13 2025,10:00am PDT
End: March 13 2025,2:00pm PDT
Duration: 4 hours
Affected Components:
Veeva Align VA-EU-SBX VA-AP-SBX
Update

March 13 2025,10:00am PDT

March 13 2025,10:00am PDT

Veeva Align sandbox instances will be upgraded to the 24R3.5 Align release.  Veeva Align sandbox environments will not be available during this time.


View Align Release Notes


View Vault Release Notes

Resolved

March 13 2025,2:00pm PDT

March 13 2025,2:00pm PDT

Scheduled Maintenance closed.