Veeva CRM Hotfix - All Regions

Maintenance
March 06 2025,4:00pm PST

Veeva CRM Hotfix - All Regions

Status: closed
Start: March 06 2025,2:00pm PST
End: March 06 2025,4:00pm PST
Duration: 2 hours
Affected Components:
Veeva MultiChannel & Integrations MC-01 MC-20 MC-30
Update

March 06 2025,2:00pm PST

March 06 2025,2:00pm PST

Veeva CRM Sandbox and Production orgs are being upgraded to the 243.4.301 release for Online Platforms. Systems are generally available during this time.

View Patch Notes

Resolved

March 06 2025,4:00pm PST

March 06 2025,4:00pm PST

Scheduled Maintenance closed.