Veeva CRM Maintenance Release - All Regions

Maintenance
March 06 2025,4:00pm PST

Veeva CRM Maintenance Release - All Regions

Status: closed
Start: March 06 2025,2:00pm PST
End: March 06 2025,4:00pm PST
Duration: 2 hours
Affected Components:
Veeva CRM US Region EU Region AP Region CRM-20 CRM-30 CRM-03 CRM-04 CRM-05 CRM-06 CRM-08 CRM-10
Update

March 06 2025,2:00pm PST

March 06 2025,2:00pm PST

Veeva CRM Sandbox and Production orgs will be upgraded to the 243.4.400 release for Online and iOS platforms. Systems are generally available during this time.

View Patch Notes

Resolved

March 06 2025,4:00pm PST

March 06 2025,4:00pm PST

Scheduled Maintenance closed.