Veeva Nitro Production Release - Europe and Americas Regions
Maintenance
February 25 2025,6:00pm PST
Veeva Nitro Production Release - Europe and Americas Regions
Status: closed
Start:
February 25 2025,4:00pm PST
End:
February 25 2025,6:00pm PST
Duration: 2 hours
Affected Components:
Veeva Nitro
NITRO-US
NITRO-EU
Update
February 25 2025,4:00pm PST
February 25 2025,4:00pm PST
Veeva Nitro production instances will be upgraded to the 243.4.101 release. Veeva Nitro will not be available during this time.
Resolved
February 25 2025,6:00pm PST
February 25 2025,6:00pm PST
Scheduled Maintenance closed.
© 2024 Veeva Trust Site