Veeva Vault Safety 24R3.5 Limited Release (APAC) - Downtime Required
Maintenance
March 06 2025,5:00pm PST
Veeva Vault Safety 24R3.5 Limited Release (APAC) - Downtime Required
Status: closed
Start:
March 06 2025,1:00pm PST
End:
March 06 2025,5:00pm PST
Duration: 4 hours
Affected Components:
Veeva Vault
Vault-AP PODs
VV3-3123
Update
March 06 2025,1:00pm PST
March 06 2025,1:00pm PST
Veeva Vault Safety Release Notification
What: Veeva Vault Safety 24R3.5 Limited Release
Estimated Vault Downtime: Up to 4 hours
Affected PODs: VV3-3123
Learn More:
- Please read the Release Notes to learn more about the new features.
- Click here to learn how to find your Vault's POD location.
For up-to-date information on Veeva Systems' service status, see the Veeva Trust Site.
If you have further questions, please submit a ticket with Veeva Product Support.
Resolved
March 06 2025,5:00pm PST
March 06 2025,5:00pm PST
Scheduled Maintenance closed.
© 2024 Veeva Trust Site