Veeva Vault EDC 24R3.5 Release Notification -Downtime Required
Maintenance
February 28 2025,7:00pm PST
Veeva Vault EDC 24R3.5 Release Notification -Downtime Required
Status: closed
Start:
February 28 2025,5:00pm PST
End:
February 28 2025,7:00pm PST
Duration: 2 hours
Affected Components:
Veeva CDMS
CDMS-US
VV1-17
Update
February 28 2025,5:00pm PST
February 28 2025,5:00pm PST
The Veeva Vault EDC service is scheduled to be upgraded. Veeva Vault EDC service will not be available during this time.
What: Veeva Vault EDC 24R3.5 Limited Release
When: Friday, February 28 at 5:00 PM PT
Estimated Duration: 2 hours
Affected PODs: VV1-17
For more details, please read the Release Notes to learn more about the new features.
Resolved
February 28 2025,7:00pm PST
February 28 2025,7:00pm PST
Scheduled Maintenance closed.
© 2024 Veeva Trust Site