Veeva Align Sandbox Release - Americas Region

Maintenance
February 13 2025,10:00pm PST

Veeva Align Sandbox Release - Americas Region

Status: closed
Start: February 13 2025,6:00pm PST
End: February 13 2025,10:00pm PST
Duration: 4 hours
Affected Components:
Veeva Align VA-US-SBX
Update

February 13 2025,6:00pm PST

February 13 2025,6:00pm PST

Veeva Align sandbox instances will be upgraded to the 24R3.4 Align release.  Veeva Align sandbox environments will not be available during this time.


View Align Release Notes


View Vault Release Notes

Resolved

February 13 2025,10:00pm PST

February 13 2025,10:00pm PST

Scheduled Maintenance closed.